Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

3x lock doesn't do anything

0 votes
2015 Subaru Impreza. Lights all programmed and blinked correctly but my 3x lock doesn't do anything.
asked Oct 4, 2021 in Subaru by Michael Wagner (190 points)

1 Answer

0 votes
Is this vehicle a push button start or a regular key start?

 

Is the vehicle/you located in Canada or the U.S.A.?
answered Oct 4, 2021 by derek ! (277,630 points)
Regular key start and USA
As stated on www.fortin.ca 3x lock is only supported on the canadian model of that vehicle. https://fortin.ca/en/vehicles/subaru/impreza/2015-standard-key/

 

You will need an rf kit as indicated on the fortin website for that vehicle.
Rfk411 not working. Reflashed my module with rfk411 settings. Blue antenna light turns on when i turn the car on but does not flash rapidly after 4x brake pedal.
to program remotes its either one of the 2 ways:

 

1- ignition ON-OFF-ON, 4x brake followed by pressing and holding button on remote for 10-12 seconds.

 

2- ignition on, press and hold valet switch until red led underneath the yellow loop begins to flash. Then press valet switch 5x, then once on the brake, then press the button on rf kit for 10-12 seconds

 

If the unit is in valet mode or armed you will not be able to program remotes. Simply enter/exit valet mode to solve this.

 

https://fortin.ca/download/68771/rfk411-install-guide-68771.pdf
Tried process 1 multiple times without any success. Entered and exited valet mode and tried again and still nothing. The blue antenna light again comes on when when I turn ignition on the second time but does not flash after brake 4x. Do I have to have the valet switch on there?
...

Wirecolor.com

the ultimate online tool

Visit wirecolor.com for wiring information and photographs providing detailed installation processes.

Email Sign Up

Get products & corporate
updates with our newsletter.